GRT backup jobs to Backup Exec Deduplication fail with error: 0xe0001203 - An error occurred while creating or accessing the directory specified for this operation.
Problem
GRT backup jobs to Backup Exec Deduplication Storage fails with error:0xe0001203 - An error occurred while creating or accessing the directory specified for this operation.
Cause
This can be caused if the Deduplication share \\.pdvfs is not available.
-- To confirm if this is the case, browse the \\.pdvfs\BEServerName path\2\BEDATA folder
Start > Run... > \\.pdvfs while logged in as the user the "Backup Exec Device & Media Service" is running under.
-- Another way to confirm would be to open a command prompt and run "net use" on the Backup Exec media server and confirm the \\.pdvfs\SERVERNAME share exists.
Solution
1. Make sure below files are present in BE Install Path.
C:\Program Files\Veritas\Backup Exec\pdvfs.dll
C:\Program Files\Veritas\Backup Exec\PDVFSProtocol.dll
C:\Program Files\Veritas\Backup Exec\PDVFSService.exe
C:\Windows\System32\PDVFSNP.dll
C:\Windows\System32\drivers\pdfsd.sys
If all files have been confirmed, make sure that the PDVFS driver and service are loaded:
PDVFS Service:
i) Open an elevated command prompt.
ii) Type "sc query pdvfsservice" and press enter. Should return the following as a result.
SERVICE_NAME: pdvfsservice
TYPE : 10 WIN32_OWN_PROCESS
STATE : 4 RUNNING (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
If this command returns with a state of "STATE : 1 STOPPED", make sure the service is running.
-- To start the service through the command prompt, type "sc start pdvfsservice" and press enter.
PDVFS Driver:
i) Open an elevated command prompt.
ii) Type "sc query pdvfsdriver" and press enter. Should return the following as a result.
SERVICE_NAME: pdvfsdriver
TYPE : 2 FILE_SYSTEM_DRIVER
STATE : 4 RUNNING (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0
2. If the STATE shows anything other than "4 RUNNING", Stop Backup Exec PureDisk FileSystem Service and restart the Backup Exec device and media service. If this does not help, a reboot of the Backup Exec Server can be tried.
3. Install any patches or updates that are available for Backup Exec.
4. A repair installation of Backup Exec using the same version ISO can be run.
If the above steps do not resolve the issue, technical support should be contacted for further assistance.