Exchange 2010 database backup fails with the following error in Job Details: "system error occurred(130)"
Problem
Exchange 2010 database backup fails with the following error in Job Details: "system error occurred(130)".
Error Message
Excerpt from Job Details:
1/2/2011 10:40:51 AM - begin Unknown Type, Create Snapshot
1/2/2011 10:40:51 AM - started process bpbrm (4384)
1/2/2011 10:40:51 AM - started
1/2/2011 10:42:21 AM - Critical bpbrm(pid=4384) from client EXCH123: FTL - snapshot creation failed - Error attempting to gather metadata., status 130
.
1/2/2011 10:42:33 AM - end Unknown Type, Delete Snapshot On Exit; elapsed time: 00:00:09
system error occurred(130)
Excerpt from client's bpfis log:
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - Private MDB (5) ***
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - displayName: MAILBOX_A_C
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - owningServer: EXCH123
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - owningServerFQDN: EXCH123.internal.priv
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - masterServerOrAvailabilityGroup: EXCHdag1
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - distinguishedName: CN=MAILBOX_A_C,CN=Databases,CN=Exchange Administrative Group (ExchAdmin),CN=Administrative Groups,CN=Symantec Global,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=priv
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - msExchMasterServerOrAvailabilityGroup: CN=EXCHdag1,CN=Database Availability Groups,CN=Exchange Administrative Group (ExchAdmin),CN=Administrative Groups,CN=Symantec Global,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=priv
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - msExchOwningServer: CN=EXCHdag1,CN=Servers,CN=Exchange Administrative Group (ExchAdmin),CN=Administrative Groups,CN=Symantec Global,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=priv
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - msExchESEParamLogFilePath: F:\Exchange Logs\MAILBOX_A_C
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - msExchESEParamSystemPath: F:\Exchange Logs\MAILBOX_A_C
10:40:51.982 [8104.6576] <2> onlfi_vfms_logf: INF - INF - msExchEDBFile: E:\Exchange Data\MAILBOX_A_C\ MAILBOX_A_C.edb
.
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - Status 0x00000002 returned calling FindFirstFile for \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Exchange Data\ MAILBOX_A_C\MAILBOX_A_C.edb in brUtil::GenerateFileList
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - Informational: Component:File no files are present to protect.
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - Component Set File has 1 files missing on the snapshot
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - brUtil:: 0x00000001 Could not get the next object to read. Probably end of list.
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - ERR - EnumerateForLocalMetaData: FS_Openbj() Failed! (0xE0009421:No component files present on the snapshot.
)
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - INF - EnumerateForLocalMetaData() exiting.
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - INF - EnumerateForLocalMetaData() exiting.
10:42:15.779 [8104.6576] <2> onlfi_vfms_logf: INF - VSS_Writer_freeze_commit: snapshot create failed
Cause
This issue occurs when the database pathname for Exchange 2010 has preceding white space character. This is regardless whether the database only has one copy or multiple copies (as in Database Availability Group).
For example: "E:\Exchange Logs\MAILBOX_A_C\ MAILBOX_A_C.edb" has a leading space before MAILBOX_A_C.edb
To verify, launch the Exchange Management Console, and browse to Organization Configuration > Mailbox and take note of the Database File Path.
Solution
To fix this issue, do not rename the database filename directly on file system. Instead, use the Move Database Path... option from within Exchange Management Console > Organization Configuration > Mailbox.
For database file path, simply retain the existing paths and remove the preceding white space from the filename. This ensures the file stays in its current location (i.e. no file movement).
Note:
- Maintenance / downtime window may be required as the procedure will dismount the database and remount it again.
- For database with multiple copies, follow the instruction in https://technet.microsoft.com/en-us/library/dd979782.aspx
Applies To
This issue has been reported on backups of Microsoft Exchange 2010 database using NetBackup 7.0.1 and 7.1.