Problem
Choosing the option to export any archive to PST fails with Event ID 6794 as shown below. It will log multiple times for each item attempted.
The following facts were also identified:
- The PST file is created in the correct location but no archived items are added to it.
- The option to export to a mailbox works without error.
- Restoring and retrieval of the same archived items from the archive is successful.
Error Message
Category : Migrator Server
Event ID: 6794
Description:Error restoring Saveset during export operation.
Job Id: Exp3_20100601170151
Vault Name: IwanttobeexportedtoPST
Vault Id: 16DE7BEF062F64E4F82DA764F3E5B0E3A1110000evalias
Saveset Id: 399000000000000~200805052200000000~0~BC438EFEF8164B23A61490B36FBFA25
Reference: RS/MAPI/CMData:
Access is denied [0x80070005]
V-437-6794
In a DTRACE of MigratorServer, you will see the following:
(MigratorServer) <XXXX> EV~E Event ID: 6794 Error restoring Saveset during export operation. | |Job Id: Exp3_20140611145932 |Vault Name: User 1 |Vault Id: 1747A700B5B451040A71499B81C3D232C1110000EV-EXCH.EV10.local |Saveset Id: 201307053056238~201205311246000000~Z~D0F2AB6780400FFE8685D9B9A9464FF1 |Reference: RS/MAPI/CM |
(MigratorServer) <XXXX> EV:H {CExchangeArchiveRestorerBase::RestoreSaveset} (Exit) Status: [Catastrophic failure (0x8000ffff)]
Cause
This issue is caused by the implementation of the PSTDisableGrow registry key on the vault server as below:
HKEY_CURRENT_USER/Software/Microsoft/Office/11/Outlook/PST/PstDisableGrow =1
HKEY_CURRENT_USER/Software/Microsoft/Office/12/Outlook/PST/PstDisableGrow = 1
HKEY_CURRENT_USER/Software/Microsoft/Office/15.0/Outlook/PST/PstDisableGrow = 1
HKEY_CURRENT_USER/Software/Microsoft/Office/16.0/Outlook/PST/PstDisableGrow = 1
15.0 indicates that Outlook 2013 is installed
16.0 indicates that Outlook 2016 or higher is installed
Solution
The solution is to bypass the PSTDisableGrow feature and to do this a hotfix available from Microsoft needs to be installed.
1. Logon to the EV server as the Vault Service Account
2. Implement the following registry keys:
If your environment does not apply group policies:
Key : HKCU/Software/Microsoft/Office/12/Outlook/PST
Type : REG_DWORD
Name : PstDisableGrow
Value : 0
Key : HKCU/Software/Microsoft/Office/12/Outlook/PST
Type : REG_DWORD
Name : PSTDisableGrowAllowAuthenticodeOverrides
Value : 1
If your environment applies group policy:
Key : HKCU/Software/policies/Microsoft/Office/12/Outlook/PST
Type : REG_DWORD
Name : PstDisableGrow
Value : 0
Key : HKCU/Software/policies/Microsoft/Office/12/Outlook/PST
Type : REG_DWORD
Name : PSTDisableGrowAllowAuthenticodeOverrides
Value : 1
If the registry keys do not exist, then you must create them manually.
3. Run the Export to PST again and it should be successful.
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.