Problem
Event ID 4143 or 4141 may be logged and the Enterprise Vault (EV) services are shutdown.
Error Message
Event Type: Error
Event Source: Enterprise Vault
Event ID: 4143
Description:
Insufficient Diskspace is available on drives %1 and %2 for the Enterprise Vault to run Enterprise Vault will now be shutdown; to correct this problem, delete any unwanted files and restart Enterprise Vaultv-437-4143
v-437-4141
Cause
The Admin service monitors all local disks. There may be a disk on the system that is nearly full, however it is not used by EV. EV services are stopped if an insufficient disk issue occurs on a local drive.
Monitoring the disk can be controlled using Start parameters in Enterprise Vault Admin Service from properties. However, if EV is configured in a cluster, startup parameters cannot be entered in Enterprise Vault Admin Service.
Solution
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
Workaround:
- Create a DWORD called DiskMap underneath HKLM\SOFTWARE\KVS\EnterpriseVault\AdminService\Disk.
- The DiskMap value is the sum of drives. Add the proper number.
For example,
If monitoring only C drive, the value becomes 4.
If monitoring C and E drives, the value becomes 20.
- Restart Enterprise Vault Admin Service.